본문 바로가기

Creo/Library

Creo (크리오, Pro/ENGINEER, 프로엔지니어)에서 Library 설정 방법

2010/02/25
 안녕하세요. 막걸리에 파전이 생각나는 날씨입니다. ^__^

Creo(크리오, Pro/ENGINEER-프로엔지니어, 프로이)에서 Library(라이브러리) 폴더를 지정하는 방법에 대한 내용입니다.
사실 방법은 매우 간단하고, config.pro에서 pro_library_dir 의 항목을 library가 있는 절대 경로로 설정을 하시면 됩니다.
즉, pro_library_dir d:\ptc\library 와 같은 형태로 하시면 되지요. 아래 동영상을 참조하시고, 궁금하시면 다시 댓글 달아 주십시오.




사업자 정보 표시
주식회사 와파 | 허환호 | 경기도 수원시 영통구 신동 486(디지털엠파이어 II) 102동 410호 | 사업자 등록번호 : 791-87-00539 | TEL : 031-214-1120 | Mail : hhuh@proe.co.kr | 사이버몰의 이용약관 바로가기
  • 익명 2010.03.30 01:57

    비밀댓글입니다

  • 최 명 택 2010.07.01 19:44

    안녕 하세요 프로이를 처음 시작 하는 사람 입니다 .
    한글 이라고 나름 설치하긴 했는데 한글도 안되고 .정말 아무것도 모르겠습니다 .
    여기서 차근 차근 배워 보고 싶은데. 도움좀 주십사 하고 글을 남깁니다 .
    shuma210@nate.com
    shuma210@naver.com
    입니다 . 연락 기다리겠습니다 .
    수고 하세요 ~

    • Favicon of https://proe.tistory.com BlogIcon 재영아빠™ 2010.07.01 21:49 신고

      뭔가 정확한 질문을 하셔야 도움을 드릴 수 있을 것 같습니다. 그리고 대부분의 블로거나 카페에서 답변은 항상 그곳에서 이루어지지 별도 메일을 발송하는 경우는 거의 없습니다.

  • 김우진 2010.08.19 15:27

    5.0을 오늘 처음 사용해 보았습니다.
    음..제 질문을 어떻게 설명을해야하나..ㅎㅎ
    우선 4.0에서 쓰던 CONFIG.PRO파일을 5.0에 넣었습니다.
    그랬더니 모양새 편집기..(모델링에 색넣는 명령?)에 있는 색들중
    라이브러리에 색들이 다 없어져있어서요
    5.0을 처음깔고 CONFIG.PRO파일을 바꾸지 않았을때는 라이브러리에 색들이 참 많았는데
    CONFIG파일을 바꾸고 나서 라이브러리에 색들이 다 없어졌습니다.
    이것만 다시 복원할 수 있을까요?

    • Favicon of https://proe.tistory.com BlogIcon 재영아빠™ 2010.08.22 17:09 신고

      5.0을 실행하고, 색상 편집기에서 강제로 4.0 데이터를 읽어오십시오. 그리고 그것을 다시 저장을 하면 *.dmt로 될 겁니다. 아마 해당 데이터가 4.0이 아닌 이전 버전에서 생성되었던 파일일 가능성이 높은 듯 합니다.

  • 김우진 2010.08.23 17:35

    아 제가 글을 잘 못써서;;;남들이 많이 햇깔려 하는데;;
    오늘도 그렇게 되었군요;;;ㅎㅎ;;
    음;;그러니까;;
    제가 하고싶었던것은 기존 5.0 라이브러리에 있던 색들을 쓰고 싶은것입니다~^^;;
    지금 현재는 4.0에서 쓰던 색들이 있고
    5.0에 기본적(?)으로 있던 라이브러리 색들이 없어져서;;

    • Favicon of https://proe.tistory.com BlogIcon 재영아빠™ 2010.08.29 10:20 신고

      요즘 워낙 바빠 답변이 늦어 죄송합니다.



      pro_colormap_path 폴더에 WF5 color 파일이 없나보군요. Graphic Library를 설치하시고, 그 위치를 config.pro에서 설정 해 주세요

  • 김우진 2010.08.30 21:41

    자꾸 쉬운 질문을 드려 정말 죄송합니다;;
    음..도구-옵션에서 config.pro 파일을 열어 pro_colormap_path에서 d:\ptc\graphic-library로 설정을 했는데 음...달라진점이 없어요;;
    제가 뭔가 잘못한건가요?;;따로 graphic library를 설치하는 법은 몰라서 우선 폴더에 있어서 설정만 했는데..

    • Favicon of https://proe.tistory.com BlogIcon 재영아빠™ 2010.08.30 22:42 신고

      서로 오해를 할 수 있으니 하시고 싶은 5.0의 color 창을 캡쳐해서 huhhwanho@지메일닷컴으로 보내주시면 제가 다시 확인을 해 보겠습니다.

  • 오학진 2011.01.24 11:21

    안녕하세요
    library 활용에 대한 질문을 드리고자 또 다시 방문하게 되었습니다.

    위의 방법대로 library를 설정해서 파트를 assembly 하면 편한데
    다음에 열때는 library folder에서 파트를 못가져와서 assembly가 안되네요
    여기에 다른 추가 팁이 있는지 해서 질문 드립니다 ^^;

    • Favicon of https://proe.tistory.com BlogIcon 재영아빠™ 2011.01.24 14:19 신고

      맞습니다. 프로이는 조립된 부품의 경로 정보를 가지고 있지 않고, 작업 디렉토리에 있거나 또는 search path에 지정된 폴더에 있는 데이터만 검색을 합니다.
      따라서 이 경우에는 search_path를 지정을 해야 하는데 이 부분은 제가 새로운 게시물로 설명을 드리겠습니다.

  • 오학진 2011.01.29 17:57

    감사합니다 지금은 일일이 볼트 너트를 작업 폴더로 복사해와서 작업중입니다.
    저장할때마다 *.IDX파일 지워 가면서 ㅎㅎ

    • Favicon of https://proe.tistory.com BlogIcon 재영아빠™ 2011.01.29 21:45 신고

      언젠가는 데이터 관리를 하는 시스템을 구축을 해야 할 텐데 동일명의 부품을 사용하면 그때 문제가 크지게 됩니다. 공용 부품은 관리를 철저히 해서 항상 유일한 데이터를 유지하게 하시는 것이 좋습니다.

  • 오학진 2011.02.01 16:04

    search_path_file이라고 하시어서
    텍스트파일 하나 만들어서 제가 사용하는 라이버리 일일이 다 물려서 사용하니깐 되던데 맞게 한건지는
    잘 모르겠어요
    줄건 연휴 보내시고 저도 암튼 해결 하나 되어서 기쁘네요 ^^
    항상 눈팅이였는데 ^^